blob: 17132aa22a78d794f26650b00c9f5b22a7bd7c04 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "IMA sample simple policy"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5# This policy file will get installed as /etc/ima/ima-policy.
6# It is located via the normal file search path, so a .bbappend
7# to this recipe can just point towards one of its own files.
8IMA_POLICY ?= "ima_policy_simple"
9
10SRC_URI = " file://${IMA_POLICY}"
11
12do_install () {
13 install -d ${D}/${sysconfdir}/ima
14 install ${WORKDIR}/${IMA_POLICY} ${D}/${sysconfdir}/ima/ima-policy
15}
16
17FILES_${PN} = "${sysconfdir}/ima"
18RDEPENDS_${PN} = "ima-evm-utils"