blob: 835dffcd81a256ba87291e2ccf2d20508da5f15c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux system security checks"
2DESCRIPTION = "The checksec script is designed to test what standard Linux OS and PaX security features are being used."
3SECTION = "security"
4LICENSE = "BSD"
5HOMEPAGE="https://github.com/slimm609/checksec.sh"
6
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=93fddcca19f6c897871f9b5f9a035f4a"
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRCREV = "3c15cb89641c700096fdec0c1904a0cf9b83c5e2"
Brad Bishop19323692019-04-05 15:28:33 -040010SRC_URI = "git://github.com/slimm609/checksec.sh"
11
12S = "${WORKDIR}/git"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/checksec ${D}${bindir}
17}
18
19RDEPENDS_${PN} = "bash openssl-bin"