blob: 4d3a96f29bcc2d6def4998cc3a4d9c8f58149866 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Linux Key Management Utilities"
2DESCRIPTION = "\
3 Utilities to control the kernel key management facility and to provide \
4 a mechanism by which the kernel call back to userspace to get a key \
5 instantiated. \
6 "
7HOMEPAGE = "http://people.redhat.com/dhowells/keyutils"
8SECTION = "base"
9
10LICENSE = "LGPLv2.1+ & GPLv2.0+"
11
12LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \
13 file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f"
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015inherit siteinfo autotools-brokensep ptest
Brad Bishop19323692019-04-05 15:28:33 -040016
17SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \
18 file://keyutils-test-fix-output-format.patch \
19 file://keyutils-fix-error-report-by-adding-default-message.patch \
20 file://run-ptest \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://fix_library_install_path.patch \
Brad Bishop19323692019-04-05 15:28:33 -040022 "
23
24SRC_URI[md5sum] = "191987b0ab46bb5b50efd70a6e6ce808"
25SRC_URI[sha256sum] = "d3aef20cec0005c0fa6b4be40079885567473185b1a57b629b030e67942c7115"
26
27EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \
28 NO_ARLIB=1 \
29 BINDIR=${base_bindir} \
30 SBINDIR=${base_sbindir} \
Brad Bishop15ae2502019-06-18 21:44:24 -040031 LIBDIR=${libdir} \
32 USRLIBDIR=${libdir} \
33 INCLUDEDIR=${includedir} \
Brad Bishop19323692019-04-05 15:28:33 -040034 BUILDFOR=${SITEINFO_BITS}-bit \
35 NO_GLIBC_KEYERR=1 \
36 "
37
38do_install () {
Brad Bishop15ae2502019-06-18 21:44:24 -040039 install -d ${D}/${libdir}/pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040040 oe_runmake DESTDIR=${D} install
41}
42
43do_install_ptest () {
44 cp -r ${S}/tests ${D}${PTEST_PATH}/
45 sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh
46}
47
Brad Bishop19323692019-04-05 15:28:33 -040048
49RDEPENDS_${PN}-ptest += "lsb"
50RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
51RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils"
Brad Bishop15ae2502019-06-18 21:44:24 -040052
53BBCLASSEXTEND = "native nativesdk"