blob: 44c8e1bf5e8703286f4161658ba9971145a68bdb [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Poky-tiny init"
2DESCRIPTION = "Basic init system for poky-tiny"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6PR = "r2"
7
8RDEPENDS_${PN} = "busybox"
9
10SRC_URI = "file://init \
11 file://rc.local.sample \
12 "
13
14S = "${WORKDIR}"
15
16do_configure() {
17 :
18}
19
20do_compile() {
21 :
22}
23
24do_install() {
25 install -d ${D}${sysconfdir}
26 install -m 0755 ${WORKDIR}/init ${D}
27 install -m 0755 ${WORKDIR}/rc.local.sample ${D}${sysconfdir}
28}
29
30FILES_${PN} = "/init ${sysconfdir}/rc.local.sample"
Brad Bishop15ae2502019-06-18 21:44:24 -040031RCONFLICTS_${PN} = "systemd"