blob: 0e5a81e31661a9ee7cc9d54080a201c5278d915e [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhboot/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "efivar popt"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
14 file://0001-remove-extra-decl.patch \
15 "
16SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
17
18S = "${WORKDIR}/git"
19
20inherit pkgconfig
21
22# The directory under the ESP that the default bootloader is found in. When
23# wic uses a subdirectory, this should use the same one too.
24EFIDIR ?= "/"
25
26EXTRA_OEMAKE += "'EFIDIR=${EFIDIR}'"
27
28CFLAGS += " -Wno-error"
29
30do_install () {
31 oe_runmake install DESTDIR="${D}"
32}
33
34CLEANBROKEN = "1"