blob: 0213e7af63d72ff737a934aecf3d2d7aa4517442 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Host side USB console utilities"
2DESCRIPTION = "Contains the lsusb utility for inspecting the devices connected to the USB bus."
3HOMEPAGE = "http://www.linux-usb.org"
4SECTION = "base"
5
6LICENSE = "GPLv2+ & (GPLv2 | GPLv3)"
7# License files went missing in 010, when 011 is released add LICENSES/* back
8LIC_FILES_CHKSUM = "file://lsusb.c;endline=1;md5=7d4861d978ff5ba7cb2b319ed1d4afe3 \
9 file://lsusb.py.in;beginline=2;endline=2;md5=194d6a0226bf90f4f683e8968878b6cd"
10
11DEPENDS = "libusb1 virtual/libiconv udev"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/usb/usbutils/usbutils-${PV}.tar.gz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014 "
Brad Bishop15ae2502019-06-18 21:44:24 -040015SRC_URI[md5sum] = "7484445cbcf04b3eacac892fe58f8d9f"
16SRC_URI[sha256sum] = "ae2e10aad530d95839b6f4d46cd41715eae6f0f1789310d793e9be21b3e7ae20"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017
18inherit autotools pkgconfig distro_features_check update-alternatives
19
20ALTERNATIVE_${PN} = "lsusb"
21ALTERNATIVE_PRIORITY = "100"
22
23# The binaries are mostly GPLv2+ apart from lsusb.py which is GPLv2 or v3.
24LICENSE_${PN} = "GPLv2+"
25LICENSE_${PN}-python = "GPLv2 | GPLv3"
26
27RRECOMMENDS_${PN} = "udev-hwdb"
28
29PACKAGE_BEFORE_PN =+ "${PN}-python"
30FILES_${PN}-python += "${bindir}/lsusb.py"
31RDEPENDS_${PN}-python = "python3-core"