blob: 637c0e6ffbddbce5b330c0acade572df6f78fb16 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
Brad Bishop15ae2502019-06-18 21:44:24 -040012PV = "4.4.6"
Brad Bishopc342db32019-05-15 21:57:59 -040013
14SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
Brad Bishop15ae2502019-06-18 21:44:24 -040015SRCREV = "398943774c5ff38baf1bc5ee088855fd8983bb05"
Brad Bishopc342db32019-05-15 21:57:59 -040016SRCBRANCH ?= "develop"
17
18PROVIDES = "virtual/crypt"
19
20FILES_${PN} = "${libdir}/libcrypt*.so.* \
21 ${libdir}/libcrypt-*.so \
22 ${libdir}/libowcrypt*.so.* \
23 ${libdir}/libowcrypt-*.so \
24"
25
26S = "${WORKDIR}/git"
27
28BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
29TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
30CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
31
32BBCLASSEXTEND = "nativesdk"