blob: 89cc1bfe20bccc4eeff0dbb2916dc163be16fcc6 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
Brad Bishop15ae2502019-06-18 21:44:24 -040017SRCREV = "43013422dbce4bcc9ed77cfe65b294caa0985ec8"
Brad Bishopc342db32019-05-15 21:57:59 -040018SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \
20 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040021 file://0003-btrfs-progs-Pass-CFLAGS-and-LDFLAGS-to-Python.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040022 "
23
24inherit autotools-brokensep pkgconfig manpages distutils3-base
25
26CLEANBROKEN = "1"
27
28PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
29EXTRA_OECONF = " --disable-zstd"
30EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
Brad Bishop15ae2502019-06-18 21:44:24 -040031EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
32EXTRA_PYTHON_CFLAGS_class-native = ""
33EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
34EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
Brad Bishopc342db32019-05-15 21:57:59 -040035
36do_configure_prepend() {
37 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
38 mkdir -p ${S}/config
39 cp -f $(automake --print-libdir)/install-sh ${S}/config/
40}
41
42S = "${WORKDIR}/git"
43
44do_install_append() {
45 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
46}
47
48BBCLASSEXTEND = "native"