blob: 43c1967c2ba082ae862880850c2fa1123a7047b5 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = " A library providing C and Python (libcURL like) API for downloading linux repository metadata and packages."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI = "git://github.com/rpm-software-management/librepo.git \
6 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
7 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
8 "
9
Brad Bishop15ae2502019-06-18 21:44:24 -040010SRCREV = "91ebe846b0320751a264116c36a665a8facf9e0e"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12S = "${WORKDIR}/git"
13
14DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
15
16inherit cmake distutils3-base pkgconfig
17
18EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DENABLE_TESTS=OFF -DENABLE_DOCS=OFF -DWITH_ZCHUNK=OFF"
19
20BBCLASSEXTEND = "native nativesdk"
21