blob: c27765bcbcbea14929cf5b512fba1f81b58eaf78 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "892f7183b178af40f205ba37128225db"
17SRC_URI[sha256sum] = "a9c254f45f89cb1dd946b689dfe433095404532a4543bdaab0b71ce0fdcdd53d"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan ptest-perl
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30do_install_prepend() {
31 # these tests require "-T" (taint) command line option
32 rm -rf ${B}/t/cwd.t
33 rm -rf ${B}/t/file.t
34}
35
Brad Bishop15ae2502019-06-18 21:44:24 -040036RDEPENDS_${PN} += "perl-module-integer perl-module-mime-base64"
37RDEPENDS_${PN}-ptest += " \
38 libtest-needs-perl \
39 perl-module-test-more \
40 perl-module-test \
41 perl-module-utf8 \
42 perl-module-extutils-makemaker \
43 perl-module-net-domain \
44 perl-module-encode \
45 perl-module-extutils-mm-unix \
46 perl-module-file-spec-functions \
47 perl-module-perlio \
48"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049
50BBCLASSEXTEND = "native"