blob: c60ef74226dccaf52facbcbf08bc6fdbcd38374c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "pkgconf provides compiler and linker configuration for development frameworks."
2DESCRIPTION = "pkgconf is a program which helps to configure compiler and linker \
3flags for development frameworks. It is similar to pkg-config from \
4freedesktop.org, providing additional functionality while also maintaining \
5compatibility."
6HOMEPAGE = "http://pkgconf.org"
7BUGTRACKER = "https://github.com/pkgconf/pkgconf/issues"
8SECTION = "devel"
9PROVIDES += "pkgconfig"
10RPROVIDES_${PN} += "pkgconfig"
11DEFAULT_PREFERENCE = "-1"
12
13# The pkgconf license seems to be functionally equivalent to BSD-2-Clause or
14# ISC, but has different wording, so needs its own name.
15LICENSE = "pkgconf"
16LIC_FILES_CHKSUM = "file://COPYING;md5=2214222ec1a820bd6cc75167a56925e0"
17
18SRC_URI = "\
19 https://distfiles.dereferenced.org/pkgconf/pkgconf-${PV}.tar.xz \
20 file://pkg-config-wrapper \
21 file://pkg-config-native.in \
22 file://pkg-config-esdk.in \
23"
Brad Bishop15ae2502019-06-18 21:44:24 -040024SRC_URI[md5sum] = "556bae2b9e0cc7b46e7c00083cb6d95d"
25SRC_URI[sha256sum] = "22b9ee38438901f9d60f180e5182821180854fa738fd071f593ea26a81da208c"
Brad Bishop19323692019-04-05 15:28:33 -040026
27inherit autotools
28
29EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'"
30
31do_install_append () {
32 # Install a wrapper which deals, as much as possible with pkgconf vs
33 # pkg-config compatibility issues.
34 install -m 0755 "${WORKDIR}/pkg-config-wrapper" "${D}${bindir}/pkg-config"
35}
36
37do_install_append_class-native () {
38 # Install a pkg-config-native wrapper that will use the native sysroot instead
39 # of the MACHINE sysroot, for using pkg-config when building native tools.
40 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
41 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native
42 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native
43 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
44 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
45 < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk
46 install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk
47}
48
49# When using the RPM generated automatic package dependencies, some packages
50# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by
51# specifying an appropriate provide.
52RPROVIDES_${PN} += "pkgconfig(pkg-config)"
53
54# Include pkg.m4 in the main package, leaving libpkgconf dev files in -dev
55FILES_${PN}-dev_remove = "${datadir}/aclocal"
56FILES_${PN} += "${datadir}/aclocal"
57
58BBCLASSEXTEND += "native nativesdk"
59
60pkgconf_sstate_fixup_esdk () {
61 if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then
62 pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}"
63 mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real
64 lnr $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
65 sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native
66 fi
67}
68
69SSTATEPOSTUNPACKFUNCS_append_class-native = " pkgconf_sstate_fixup_esdk"