blob: 939c15bcc6304448cbf47d0606cab4cc191d5021 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
7SRC_URI[md5sum] = "9f9c163e8bd48cf8cd92f03e85ca6395"
8SRC_URI[sha256sum] = "df676f23dc6d4bfa384fc389d95dcd21ab907e6349d4c848958ba4befb73c73e"
9
10S = "${WORKDIR}/scons-${PV}"
11
12UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
13UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
14
15inherit setuptools
16
17RDEPENDS_${PN} = "\
18 python-fcntl \
19 python-io \
20 python-json \
21 python-subprocess \
22 python-shell \
23 python-pprint \
24 "