blob: 964dcee524250b9fd0e4568e65a16a1f11b62eb2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
Brad Bishop15ae2502019-06-18 21:44:24 -04008DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
Brad Bishopc342db32019-05-15 21:57:59 -04009
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm"
13
14# Handle distros such as CentOS 5 32-bit that do not have kvm support
15PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
16
17do_install_append() {
18 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
19
20 # The following is also installed by qemu-native
21 rm -f ${D}${datadir}/qemu/trace-events-all
22 rm -rf ${D}${datadir}/qemu/keymaps
23 rm -rf ${D}${datadir}/icons/
24}