blob: 85f0ff75625f18f52f70450d84b23aba39e3de4f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
30 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
31 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
32 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
33 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
34 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
35 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
36 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
37 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
38 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
39 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
40 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
41 file://0002-valgrind-adjust-std_list-expected-output.patch \
42 "
43SRC_URI[md5sum] = "46e5fbdcbc3502a5976a317a0860a975"
44SRC_URI[sha256sum] = "417c7a9da8f60dd05698b3a7bc6002e4ef996f14c13f0ff96679a16873e78ab1"
45UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
46
47COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
48
49# valgrind supports armv7 and above
50COMPATIBLE_HOST_armv4 = 'null'
51COMPATIBLE_HOST_armv5 = 'null'
52COMPATIBLE_HOST_armv6 = 'null'
53
54# X32 isn't supported by valgrind at this time
55COMPATIBLE_HOST_linux-gnux32 = 'null'
56COMPATIBLE_HOST_linux-muslx32 = 'null'
57
58# Disable for some MIPS variants
59COMPATIBLE_HOST_mipsarchr6 = 'null'
60COMPATIBLE_HOST_linux-gnun32 = 'null'
61
62# Disable for powerpc64 with musl
63COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
64
65inherit autotools ptest multilib_header
66
67EXTRA_OECONF = "--enable-tls --without-mpicc"
68EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
69
70# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
71EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
72
73EXTRA_OEMAKE = "-w"
74
75CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
76
77# valgrind likes to control its own optimisation flags. It generally defaults
78# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
79# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
80# which fixes build path issue in DWARF.
81SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
82
83do_configure_prepend () {
84 rm -rf ${S}/config.h
85 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
86 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
87}
88
89do_install_append () {
90 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
91 oe_multilib_header valgrind/config.h
92}
93
94VALGRINDARCH ?= "${TARGET_ARCH}"
95VALGRINDARCH_aarch64 = "arm64"
96VALGRINDARCH_x86-64 = "amd64"
97VALGRINDARCH_x86 = "x86"
98VALGRINDARCH_mips = "mips32"
99VALGRINDARCH_mipsel = "mips32"
100VALGRINDARCH_mips64el = "mips64"
101VALGRINDARCH_powerpc = "ppc"
102VALGRINDARCH_powerpc64 = "ppc64"
103VALGRINDARCH_powerpc64el = "ppc64le"
104
105INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
106
107RDEPENDS_${PN} += "perl"
108
109# valgrind needs debug information for ld.so at runtime in order to
110# redirect functions like strlen.
111RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
112
Brad Bishop15ae2502019-06-18 21:44:24 -0400113RDEPENDS_${PN}-ptest += " file perl perl-module-file-glob sed ${PN}-dbg"
Brad Bishopc342db32019-05-15 21:57:59 -0400114RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
115
116# One of the tests contains a bogus interpreter path on purpose.
117# Skip file dependency check
118SKIP_FILEDEPS_${PN}-ptest = '1'
119INSANE_SKIP_${PN}-ptest = "debug-deps"
120
121do_compile_ptest() {
122 oe_runmake check
123}
124
125do_install_ptest() {
126 chmod +x ${B}/tests/vg_regtest
127
128 # The test application binaries are not automatically installed.
129 # Grab them from the build directory.
130 #
131 # The regression tests require scripts and data files that are not
132 # copied to the build directory. They must be copied from the
133 # source directory.
134 saved_dir=$PWD
135 for parent_dir in ${S} ${B} ; do
136 cd $parent_dir
137
138 # exclude shell or the package won't install
139 rm -rf none/tests/shell* 2>/dev/null
140
141 subdirs=" \
142 cachegrind/tests \
143 callgrind/tests \
144 drd/tests \
145 gdbserver_tests \
146 helgrind/tests \
147 massif/tests \
148 memcheck/tests \
149 none/tests \
150 tests \
151 "
152
153 # Get the vg test scripts, filters, and expected files
154 for dir in $subdirs ; do
155 find $dir | cpio -pvdu ${D}${PTEST_PATH}
156 done
157 cd $saved_dir
158 done
159
160 # Hide then restore a.c that is used by ann[12].vgtest in call/cachegrind
161 mv ${D}${PTEST_PATH}/cachegrind/tests/a.c ${D}${PTEST_PATH}/cachegrind/tests/a_c
162 # clean out build artifacts before building the rpm
163 find ${D}${PTEST_PATH} \
164 \( -name "Makefile*" \
165 -o -name "*.o" \
166 -o -name "*.c" \
167 -o -name "*.S" \
168 -o -name "*.h" \) \
169 -exec rm {} \;
170 mv ${D}${PTEST_PATH}/cachegrind/tests/a_c ${D}${PTEST_PATH}/cachegrind/tests/a.c
Brad Bishop15ae2502019-06-18 21:44:24 -0400171 touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test
Brad Bishopc342db32019-05-15 21:57:59 -0400172
173 # find *_annotate in ${bindir} for yocto build
174 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
175 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
176
177 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
178 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
179
180 # needed by massif tests
181 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
182
183 # handle multilib
184 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
185}