blob: cf6db336a6f6b5d111a7f84b2a524172a70517d8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "BSD | GPLv2"
13LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "bison flex bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz"
Brad Bishop15ae2502019-06-18 21:44:24 -040020SRC_URI[md5sum] = "dd1f8240f924b12b0a0de0c31ab26ab1"
21SRC_URI[sha256sum] = "860b5f94a0590b278592acf16a4556b05ff0309c08e8c48aa29827cfa02c8e9d"
Brad Bishopc342db32019-05-15 21:57:59 -040022UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix2-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "acpixtract acpidump"
30
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
37 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES_${PN} += "iasl"
46RREPLACES_${PN} += "iasl"
47RCONFLICTS_${PN} += "iasl"
48
49BBCLASSEXTEND = "native"