blob: 80a1c8e39b370ce6946c97a26be2636d01c9aa3f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Perl module for using and building Perl SAX2 XML processors"
2HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/"
3DESCRIPTION = "XML::SAX consists of several framework classes for using and \
4building Perl SAX2 XML parsers, filters, and drivers. It is designed \
5around the need to be able to "plug in" different SAX parsers to an \
6application without requiring programmer intervention. Those of you \
7familiar with the DBI will be right at home. Some of the designs \
8come from the Java JAXP specification (SAX part), only without the \
9javaness."
10
11SECTION = "libs"
12LICENSE = "Artistic-1.0 | GPL-1.0+"
13DEPENDS += "libxml-namespacesupport-perl-native"
14RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "861a454f7bf269990ed2c1c125f4db48"
21SRC_URI[sha256sum] = "45ea6564ef8692155d57b2de0862b6442d3c7e29f4a9bc9ede5d7ecdc74c2ae3"
22
23S = "${WORKDIR}/XML-SAX-${PV}"
24
25inherit cpan ptest-perl
26
27do_install_ptest() {
28 cp -r ${B}/testfiles ${D}${PTEST_PATH}
29 chown -R root:root ${D}${PTEST_PATH}/testfiles
30}
31
Brad Bishop15ae2502019-06-18 21:44:24 -040032RDEPENDS_${PN} += "perl-module-encode perl-module-perlio"
33RDEPENDS_${PN}-ptest += "perl-module-test perl-module-base perl-module-fatal perl-module-encode-unicode perl-module-encode-byte"
34
Brad Bishop19323692019-04-05 15:28:33 -040035BBCLASSEXTEND = "native nativesdk"