blob: 18f09b5711c7c58042edcd313709df7db29e024d [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU file archiving program"
2DESCRIPTION = "GNU tar saves many files together into a single tape \
3or disk archive, and can restore individual files from the archive."
4HOMEPAGE = "http://www.gnu.org/software/tar/"
5SECTION = "base"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \
Brad Bishopc342db32019-05-15 21:57:59 -040010 file://musl_dirent.patch \
11"
12
13SRC_URI[md5sum] = "17917356fff5cb4bd3cd5a6c3e727b05"
14SRC_URI[sha256sum] = "e4bb9e08e12e7fa9f11fef544efc85e59ba34538593d9ad38148c7ca2bfbb566"
15
16inherit autotools gettext texinfo
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}"
20
21PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl"
22
23EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
24
25# Let aclocal use the relative path for the m4 file rather than the
26# absolute since tar has a lot of m4 files, otherwise there might
27# be an "Argument list too long" error when it is built in a long/deep
28# directory.
29acpaths = "-I ./m4"
30
31do_install () {
32 autotools_do_install
33 ln -s tar ${D}${bindir}/gtar
34}
35
36do_install_append_class-target() {
37 if [ "${base_bindir}" != "${bindir}" ]; then
38 install -d ${D}${base_bindir}
39 mv ${D}${bindir}/tar ${D}${base_bindir}/tar
40 mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
41 rmdir ${D}${bindir}/
42 fi
43}
44
45PACKAGES =+ "${PN}-rmt"
46
47FILES_${PN}-rmt = "${sbindir}/rmt*"
48
49inherit update-alternatives
50
51ALTERNATIVE_PRIORITY = "100"
52
53ALTERNATIVE_${PN} = "tar"
54ALTERNATIVE_${PN}-rmt = "rmt"
55ALTERNATIVE_${PN}_class-nativesdk = ""
56ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
57
58ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
59ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
60
61PROVIDES_append_class-native = " tar-replacement-native"
62NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
63
64BBCLASSEXTEND = "native nativesdk"