blob: 525721f0ae8a077daf9e7e141831e7387e49d80f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
21
Brad Bishop15ae2502019-06-18 21:44:24 -040022SRC_URI[md5sum] = "5b5ace9de3f07cb7b8f4d19b6979adf0"
23SRC_URI[sha256sum] = "e9e053908591b121793eaa5d8aa37675b4cd3af4b12f1f377dff4767f39cee70"
Brad Bishop19323692019-04-05 15:28:33 -040024
25UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
26
27DEPENDS = "libdrm virtual/mesa"
28
29inherit autotools pkgconfig distro_features_check
30
31REQUIRED_DISTRO_FEATURES = "opengl"
32
33EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
34
35PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
36PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
37PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
38
39PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
40
41RDEPENDS_${PN}-x11 =+ "${PN}"
42RDEPENDS_${PN}-glx =+ "${PN}-x11"
43
44FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
45FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
46FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"