blob: 129a47df48d54430162638eb359bee607e3d5f25 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRC_URI = "https://mesa.freedesktop.org/archive/demos/${BPN}-${PV}.tar.bz2 \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
15 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
16 file://0007-Install-few-more-test-programs.patch \
17 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
18 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
19 file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
20 file://0013-only-build-GLX-demos-if-needed.patch \
21 "
Brad Bishop15ae2502019-06-18 21:44:24 -040022SRC_URI[md5sum] = "6b65a02622765522176d00f553086fa3"
23SRC_URI[sha256sum] = "01e99c94a0184e63e796728af89bfac559795fb2a0d6f506fa900455ca5fff7d"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060024
25inherit autotools pkgconfig distro_features_check
26# depends on virtual/egl, virtual/libgl ...
27REQUIRED_DISTRO_FEATURES = "opengl x11"
28
29PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
30 x11 glew glu glx"
31
32# The Wayland code doesn't work with Wayland 1.0, so disable it for now
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033#${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034
35EXTRA_OECONF = "--with-system-data-files"
36
37PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
38PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
39PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
40PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
41PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
42PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050043PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,freeglut"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060044PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
45PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
46PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
47PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
48PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
49PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
50PACKAGECONFIG[glx] = "--enable-glx-demos,--disable-glx-demos"
51
52do_install_append() {
53 # it can be completely empty when all PACKAGECONFIG options are disabled
54 rmdir --ignore-fail-on-non-empty ${D}${bindir}
55
56 if [ -f ${D}${bindir}/clear ]; then
57 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
58 fi
59}