blob: a9c463cf0876c6567bda40c5e099440da814ac94 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001KBRANCH ?= "v5.0/standard/tiny/base"
2KBRANCH_qemuarm ?= "v5.0/standard/tiny/arm-versatile-926ejs"
3
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009LINUX_VERSION ?= "5.0.19"
Brad Bishop19323692019-04-05 15:28:33 -040010LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
Brad Bishop15ae2502019-06-18 21:44:24 -040018SRCREV_machine_qemuarm ?= "fabee455f397ba8054f35a3ad5f2250bbad93bef"
19SRCREV_machine ?= "00638cdd8f92869a0f89ebe3289fdbd856ba9458"
20SRCREV_meta ?= "31de88e51d100f2c3eefb7acb7390b0144bcfc69"
Brad Bishop19323692019-04-05 15:28:33 -040021
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.0;destsuffix=${KMETA}"
26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
32KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"