blob: 2c63ee7522241104f28a64ea6dd6edf3510432eb [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "ALSA sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
7 file://src/socket.c;md5=dd1bc7f44872690224d89c1a9806e495;beginline=1;endline=26 \
8 "
9
10SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2"
Brad Bishop15ae2502019-06-18 21:44:24 -040011SRC_URI[md5sum] = "e6d429dbdcfaa0f034d907fa6dc3735e"
12SRC_URI[sha256sum] = "488373aef5396682f3a411a6d064ae0ad196b9c96269d0bb912fbdeec94b994b"
Brad Bishop19323692019-04-05 15:28:33 -040013
14inherit autotools pkgconfig
15
16EXTRA_OECONF += " \
17 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-softfloat', '', d)} \
18 --disable-python \
19"
20
21PACKAGES =+ "alsa-server alsa-conf alsa-doc"
22
23FILES_alsa-server = "${bindir}/*"
24FILES_alsa-conf = "${datadir}/alsa/"
25
26RDEPENDS_${PN}_class-target = "alsa-conf"
27
28# upgrade path
29RPROVIDES_${PN} = "libasound"
30RREPLACES_${PN} = "libasound"
31RCONFLICTS_${PN} = "libasound"
32
33RPROVIDES_${PN}-dev = "alsa-dev"
34RREPLACES_${PN}-dev = "alsa-dev"
35RCONFLICTS_${PN}-dev = "alsa-dev"
36
37RPROVIDES_alsa-conf = "alsa-conf-base"
38RREPLACES_alsa-conf = "alsa-conf-base"
39RCONFLICTS_alsa-conf = "alsa-conf-base"
40
41BBCLASSEXTEND = "native nativesdk"