blob: f2a3afbbfe38ab1a060b4e4f472594a858ec824d [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GStreamer examples (including gtk-play, gst-play)"
2LICENSE = "LGPL-2.0+"
3LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9"
4
5DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 glib-2.0-native"
6
Brad Bishop19323692019-04-05 15:28:33 -04007SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https \
Brad Bishop316dfdd2018-06-25 12:45:53 -04008 file://0001-Make-player-examples-installable.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -04009 file://gst-player.desktop \
10 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRCREV = "d953c127c1146b50d5676618299933950685dcd7"
13PV = "1.16.0"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig distro_features_check
18
19
20ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
21
22do_install_append() {
23 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
24}
25
26RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback"
27RRECOMMENDS_${PN} = "gstreamer1.0-plugins-base-meta \
28 gstreamer1.0-plugins-good-meta \
29 gstreamer1.0-plugins-bad-meta \
30 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \
31 ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}"
32RPROVIDES_${PN} += "gst-player gst-player-bin"