blob: ad831ed25ce4b83d95f1d6df01f6aa019945ecfe [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001require gstreamer1.0-plugins.inc
2
3SRC_URI = " \
4 http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
Brad Bishop15ae2502019-06-18 21:44:24 -04005 file://0001-scaletempo-Advertise-interleaved-layout-in-caps-temp.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
7 "
8
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRC_URI[md5sum] = "d1a7b442994d9522418de4af4330e034"
10SRC_URI[sha256sum] = "654adef33380d604112f702c2927574cfc285e31307b79e584113858838bb0fd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12S = "${WORKDIR}/gst-plugins-good-${PV}"
13
14LICENSE = "GPLv2+ & LGPLv2.1+"
15LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
16 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
17 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
18
19DEPENDS += "gstreamer1.0-plugins-base libcap"
20RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
21RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
22
23inherit gettext
24
25PACKAGECONFIG ??= " \
26 ${GSTREAMER_ORC} \
27 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
28 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 zlib \
29"
30
31X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
32
33PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
34PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
35PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
36PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
37PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
38PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
39PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
40PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
41PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
42PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame"
43PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
44PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
45PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123"
46PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
47PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
48PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
49PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
50PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
51PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
52PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
53PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
54PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
55
56# qt5 support is disabled, because it is not present in OE core, and requires more work than
57# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
58# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
59# in a gstreamer1.0-plugins-good bbappend).
60
61EXTRA_OECONF += " \
62 --enable-oss \
63 --disable-aalib \
64 --disable-aalibtest \
65 --disable-directsound \
66 --disable-libcaca \
67 --disable-libdv \
68 --disable-oss4 \
69 --disable-osx_audio \
70 --disable-osx_video \
71 --disable-qt \
72 --disable-shout2 \
73 --disable-twolame \
74 --disable-waveform \
75"
76
77FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"