blob: 11a0e790ea65b24c15de4fba4f89813357aa31e8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001require gstreamer1.0-plugins.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
4 file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068"
5
6LICENSE = "GPLv2+ & LGPLv2.1+ & LGPLv2+"
7LICENSE_FLAGS = "commercial"
8
9SRC_URI = " \
10 http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.xz \
11 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
12 "
Brad Bishop15ae2502019-06-18 21:44:24 -040013SRC_URI[md5sum] = "1ec343c58d4b17d682f7befa8453c11c"
14SRC_URI[sha256sum] = "e30964c5f031c32289e0b25e176c3c95a5737f2052dfc81d0f7427ef0233a4c2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16S = "${WORKDIR}/gst-plugins-ugly-${PV}"
17
Brad Bishop19323692019-04-05 15:28:33 -040018DEPENDS += "gstreamer1.0-plugins-base"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
20inherit gettext
21
22PACKAGECONFIG ??= " \
23 ${GSTREAMER_ORC} \
24 a52dec mpeg2dec \
25"
26
27PACKAGECONFIG[a52dec] = "--enable-a52dec,--disable-a52dec,liba52"
28PACKAGECONFIG[amrnb] = "--enable-amrnb,--disable-amrnb,opencore-amr"
29PACKAGECONFIG[amrwb] = "--enable-amrwb,--disable-amrwb,opencore-amr"
30PACKAGECONFIG[cdio] = "--enable-cdio,--disable-cdio,libcdio"
31PACKAGECONFIG[dvdread] = "--enable-dvdread,--disable-dvdread,libdvdread"
32PACKAGECONFIG[mpeg2dec] = "--enable-mpeg2dec,--disable-mpeg2dec,mpeg2dec"
33PACKAGECONFIG[x264] = "--enable-x264,--disable-x264,x264"
34
35EXTRA_OECONF += " \
36 --disable-sidplay \
37"
38
39FILES_${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
40FILES_${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"