blob: 0f3aac19065fd0a1edd8aa46057c06ad644e3f25 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
Brad Bishop15ae2502019-06-18 21:44:24 -04009SRC_URI[md5sum] = "877b2ed2aaffdb62e63f38ea9469b70f"
10SRC_URI[sha256sum] = "55dc7aaed1855565f9b9ef842d93e93bfc5cb2b376faef6af5b463e1774e2d38"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
Brad Bishopc342db32019-05-15 21:57:59 -040019# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
Brad Bishop15ae2502019-06-18 21:44:24 -040025EXTRA_OECONF += "--with-libpython-dir=${libdir}"
26
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027do_install_append() {
Brad Bishop15ae2502019-06-18 21:44:24 -040028
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 # Note that this particular find line is taken from the Debian packaging for
30 # gst-python1.0.
31 find "${D}" \
32 -name '*.pyc' -o \
33 -name '*.pyo' -o \
34 -name '*.la' -o \
35 -name 'libgstpythonplugin*' \
36 -delete
37}