blob: e5dfb612417faa18e764d20e0a5d5399c8e34980 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
12 file://0001-gst-vaapi-Makefile.am-Add-EGL_CFLAGS-to-libgstvaapi-.patch \
13 file://0001-vaapsink-downgrade-to-marginal.patch \
14 "
15
Brad Bishop15ae2502019-06-18 21:44:24 -040016SRC_URI[md5sum] = "8c3f9ee3e47cbdb75a94f7183460b721"
17SRC_URI[sha256sum] = "4e7fce626ee0590dca74b5a8341d25bac76307945131a970b414fc5895f5171f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19S = "${WORKDIR}/${REALPN}-${PV}"
20DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
21
22inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even
23
24REQUIRED_DISTRO_FEATURES ?= "opengl"
25
26PACKAGES =+ "${PN}-tests"
27
28# OpenGL packageconfig factored out to make it easy for distros
29# and BSP layers to pick either glx, egl, or no GL. By default,
30# try detecting X11 first, and if found (with OpenGL), use GLX,
31# otherwise try to check if EGL can be used.
32PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
33 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
34 '', d), d)}"
35
36PACKAGECONFIG ??= "drm \
37 ${PACKAGECONFIG_GL} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
39
40PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
41PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
42PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl"
Brad Bishop15ae2502019-06-18 21:44:24 -040043PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
45
46FILES_${PN} += "${libdir}/gstreamer-*/*.so"
47FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
48FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
49FILES_${PN}-tests = "${bindir}/*"