blob: efd9eaa71e4c1ccac4175e85fd7d4c5d82299e5d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Common CA certificates"
2DESCRIPTION = "This package includes PEM files of CA certificates to allow \
3SSL-based applications to check for the authenticity of SSL connections. \
4This derived from Debian's CA Certificates."
5HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
6SECTION = "misc"
7LICENSE = "GPL-2.0+ & MPL-2.0"
8LIC_FILES_CHKSUM = "file://debian/copyright;md5=aeb420429b1659507e0a5a1b123e8308"
9
10# This is needed to ensure we can run the postinst at image creation time
11DEPENDS = ""
12DEPENDS_class-native = "openssl-native"
13DEPENDS_class-nativesdk = "openssl-native"
Brad Bishop19323692019-04-05 15:28:33 -040014# Need rehash from openssl and run-parts from debianutils
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGE_WRITE_DEPS += "openssl-native debianutils-native"
16
Brad Bishopf8caae32019-03-25 13:13:56 -040017SRCREV = "c28799b138b044c963d24c4a69659b6e5486e3be"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19SRC_URI = "git://salsa.debian.org/debian/ca-certificates.git;protocol=https \
20 file://0002-update-ca-certificates-use-SYSROOT.patch \
21 file://0001-update-ca-certificates-don-t-use-Debianisms-in-run-p.patch \
22 file://update-ca-certificates-support-Toybox.patch \
23 file://default-sysroot.patch \
24 file://sbindir.patch \
25 file://0003-update-ca-certificates-use-relative-symlinks-from-ET.patch \
26 "
27
28S = "${WORKDIR}/git"
29
30inherit allarch
31
32EXTRA_OEMAKE = "\
33 'CERTSDIR=${datadir}/ca-certificates' \
34 'SBINDIR=${sbindir}' \
35"
36
37do_compile_prepend() {
38 oe_runmake clean
39}
40
41do_install () {
42 install -d ${D}${datadir}/ca-certificates \
43 ${D}${sysconfdir}/ssl/certs \
44 ${D}${sysconfdir}/ca-certificates/update.d
45 oe_runmake 'DESTDIR=${D}' install
46
47 install -d ${D}${mandir}/man8
48 install -m 0644 sbin/update-ca-certificates.8 ${D}${mandir}/man8/
49
50 install -d ${D}${sysconfdir}
51 {
52 echo "# Lines starting with # will be ignored"
53 echo "# Lines starting with ! will remove certificate on next update"
54 echo "#"
55 find ${D}${datadir}/ca-certificates -type f -name '*.crt' | \
56 sed 's,^${D}${datadir}/ca-certificates/,,'
57 } >${D}${sysconfdir}/ca-certificates.conf
58}
59
60do_install_append_class-target () {
61 sed -i -e 's,/etc/,${sysconfdir}/,' \
62 -e 's,/usr/share/,${datadir}/,' \
63 -e 's,/usr/local,${prefix}/local,' \
64 ${D}${sbindir}/update-ca-certificates \
65 ${D}${mandir}/man8/update-ca-certificates.8
66}
67
68pkg_postinst_${PN}_class-target () {
69 SYSROOT="$D" $D${sbindir}/update-ca-certificates
70}
71
72CONFFILES_${PN} += "${sysconfdir}/ca-certificates.conf"
73
74# Rather than make a postinst script that works for both target and nativesdk,
75# we just run update-ca-certificate from do_install() for nativesdk.
76CONFFILES_${PN}_append_class-nativesdk = " ${sysconfdir}/ssl/certs/ca-certificates.crt"
77do_install_append_class-nativesdk () {
78 SYSROOT="${D}${SDKPATHNATIVE}" ${D}${sbindir}/update-ca-certificates
79}
80
81do_install_append_class-native () {
82 SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates
83}
84
Brad Bishop15ae2502019-06-18 21:44:24 -040085RDEPENDS_${PN}_class-target = "openssl-bin"
86RDEPENDS_${PN}_class-native = "openssl-native"
87RDEPENDS_${PN}_class-nativesdk = "nativesdk-openssl-bin"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080088
89BBCLASSEXTEND = "native nativesdk"