blob: 50b26753b4f9d70b4a5408c6701695120d083a87 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD"
Brad Bishop15ae2502019-06-18 21:44:24 -040011LIC_FILES_CHKSUM = "file://LICENCE;md5=b1588d3bb4cb0e1f5a597d908f8c5b37"
Brad Bishop19323692019-04-05 15:28:33 -040012
13SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2 \
14 file://pcre-cross.patch \
15"
16
Brad Bishop15ae2502019-06-18 21:44:24 -040017SRC_URI[md5sum] = "80b355f2dce909a2e2424f5c79eddb44"
18SRC_URI[sha256sum] = "35514dff0ccdf02b55bd2e9fa586a1b9d01f62332c3356e379eabb75f789d8aa"
Brad Bishop19323692019-04-05 15:28:33 -040019
20CVE_PRODUCT = "pcre2"
21
22S = "${WORKDIR}/pcre2-${PV}"
23
24PROVIDES += "pcre2"
25DEPENDS += "bzip2 zlib"
26
27BINCONFIG = "${bindir}/pcre2-config"
28
29inherit autotools binconfig-disabled
30
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --enable-rebuild-chartables \
34 --with-link-size=2 \
35 --with-match-limit=10000000 \
36 --enable-pcre2-16 \
37 --enable-pcre2-32 \
38"
39# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
40# set CFLAGS_FOR_BUILD, required for the libpcre build.
41BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}/src"
42CFLAGS += "-D_REENTRANT"
43CXXFLAGS_append_powerpc = " -lstdc++"
44
45export CCLD_FOR_BUILD ="${BUILD_CCLD}"
46
47PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
48
49SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
50SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
51SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
52SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
53
54FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*"
55FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*"
56FILES_pcre2grep = "${bindir}/pcre2grep"
57FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
58FILES_pcre2test = "${bindir}/pcre2test"
59FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
60
61BBCLASSEXTEND = "native nativesdk"