blob: b97af08b2504e83f0de51f40c8be4a9414670618 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=91bee59d1b327eb1599b4c673e2fb3d1"
10SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre-${PV}.tar.bz2 \
11 file://fix-pcre-name-collision.patch \
12 file://out-of-tree.patch \
13 file://run-ptest \
14 file://Makefile \
15"
16
17SRC_URI[md5sum] = "636222e79e392c3d95dcc545f24f98c4"
18SRC_URI[sha256sum] = "91e762520003013834ac1adb4a938d53b22a216341c061b0cf05603b290faf6b"
19
20CVE_PRODUCT = "pcre"
21
22S = "${WORKDIR}/pcre-${PV}"
23
24PROVIDES += "pcre"
25DEPENDS += "bzip2 zlib"
26
27PACKAGECONFIG ??= "pcre8 unicode-properties jit"
28
29PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
30PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
31PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
32PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
33PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties"
34PACKAGECONFIG[jit] = "--enable-jit=auto,--disable-jit"
35
36BINCONFIG = "${bindir}/pcre-config"
37
38inherit autotools binconfig-disabled ptest
39
40EXTRA_OECONF = "--enable-utf"
41
42PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
43
44SUMMARY_libpcrecpp = "${SUMMARY} - C++ wrapper functions"
45SUMMARY_libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
46SUMMARY_pcregrep = "grep utility that uses perl 5 compatible regexes"
47SUMMARY_pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
48SUMMARY_pcretest = "program for testing Perl-comatible regular expressions"
49SUMMARY_pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
50
51FILES_libpcrecpp = "${libdir}/libpcrecpp.so.*"
52FILES_libpcreposix = "${libdir}/libpcreposix.so.*"
53FILES_pcregrep = "${bindir}/pcregrep"
54FILES_pcregrep-doc = "${mandir}/man1/pcregrep.1"
55FILES_pcretest = "${bindir}/pcretest"
56FILES_pcretest-doc = "${mandir}/man1/pcretest.1"
57
58BBCLASSEXTEND = "native nativesdk"
59
60do_install_ptest() {
61 t=${D}${PTEST_PATH}
62 cp ${WORKDIR}/Makefile $t
63 cp -r ${S}/testdata $t
64 for i in pcre_stringpiece_unittest pcregrep pcretest; \
65 do cp ${B}/.libs/$i $t; \
66 done
67 for i in RunTest RunGrepTest test-driver; \
68 do cp ${S}/$i $t; \
69 done
70 # Skip the fr_FR locale test. If the locale fr_FR is found, it is tested.
71 # If not found, the test is skipped. The test program assumes fr_FR is non-UTF-8
72 # locale so the test fails if fr_FR is UTF-8 locale.
73 sed -i -e 's:do3=yes:do3=no:g' ${D}${PTEST_PATH}/RunTest
74}
Brad Bishop15ae2502019-06-18 21:44:24 -040075
76RDEPENDS_${PN}-ptest += "make"