blob: 54455da1bb72f92e43ad6a92e199f7587bf990cb [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit autotools gettext pkgconfig gtk-doc
6
7DEPENDS = "libtasn1 libffi"
8
9SRC_URI = "git://github.com/p11-glue/p11-kit \
10 file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \
11 "
Brad Bishop15ae2502019-06-18 21:44:24 -040012SRCREV = "c689917b393379d288b868f70b2f7b7f6aafe430"
Brad Bishop19323692019-04-05 15:28:33 -040013S = "${WORKDIR}/git"
14
15AUTOTOOLS_AUXDIR = "${S}/build/litter"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[trust-paths] = "--with-trust-paths=/etc/ssl/certs/ca-certificates.crt,--without-trust-paths,,ca-certificates"
19
20# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
21# that control gtk-doc build are non-standard
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
23 '--disable-doc', d)} "
24
25# When building native recipes, disable gtkdoc, as it is not necessary,
26# pulls in additional dependencies, and makes build times longer
27EXTRA_OECONF_prepend_class-native = "--disable-doc "
28EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
29
30UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
31
32# p11-kit relies on these two being copied from source tree
33# instead of being regenerated by gtkdoc-scan, but doesn't setup
34# dependencies correctly when there is a parallel build. Let's pre-copy
35# them instead.
36do_compile_prepend () {
37 cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
38}
39
40FILES_${PN} += " \
41 ${libdir}/p11-kit-proxy.so \
42 ${libdir}/pkcs11/*.so \
43 ${libdir}/pkcs11/*.la"
44
45# PN contains p11-kit-proxy.so, a symlink to a loadable module
46INSANE_SKIP_${PN} = "dev-so"