blob: 702436b368855f9ad1121fb12d3bc24a0e6e2933 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
Brad Bishop15ae2502019-06-18 21:44:24 -04003LICENSE = "GPLv3 & LGPLv3+ & LGPLv2.1+"
4LICENSE_libvte = "LGPLv3+"
Brad Bishopc342db32019-05-15 21:57:59 -04005
6LIC_FILES_CHKSUM = " \
7 file://COPYING.GPL3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \
8 file://COPYING.LGPL2;md5=4fbd65380cdd255951079008b364516c \
9 file://COPYING.LGPL3;md5=b52f2d57d10c4f7ee67a7eb9615d5d24 \
10"
11
12DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native"
13
14inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
15
16# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
17SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
19 file://0001-app.cc-use-old-school-asignment-to-avoid-gcc-4.8-err.patch \
20 file://0001-Add-W_EXITCODE-macro-for-non-glibc-systems.patch \
21 "
22SRC_URI[archive.md5sum] = "a8984cd5a101dbff0b0c875d1de3f692"
23SRC_URI[archive.sha256sum] = "02fa8ecc02a9332e47f486795494527b5687b3bd448e73e6b67285f2f326dc7c"
24
25ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
26
27# Instead of "inherit vala" we do the relevant settings here so we can
28# set DEPENDS based on PACKAGECONFIG.
29
30# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
31export STAGING_DATADIR
32# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
33export XDG_DATA_DIRS = "${STAGING_DATADIR}"
34
35# Help g-ir-scanner find the .so for linking
36do_compile_prepend() {
37 export GIR_EXTRA_LIBS_PATH="${B}/src/.libs"
38}
39
40# Package additional files
41FILES_${PN}-dev += "${datadir}/vala/vapi/*"
42
43PACKAGECONFIG ??= "gnutls"
44PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
45PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
46
47CFLAGS += "-D_GNU_SOURCE"
48
49# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
50# Use libtool-cross (which has a hack to prevent that) instead.
51EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
52
53PACKAGES =+ "libvte ${PN}-prompt"
54FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"
55FILES_${PN}-prompt = "${sysconfdir}/profile.d"
56
57BBCLASSEXTEND = "native nativesdk"