Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Generic XKB keymap library" |
| 2 | DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \ |
| 3 | processes a reduced subset of keymaps as defined by the XKB specification." |
| 4 | HOMEPAGE = "http://www.xkbcommon.org" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87" |
| 6 | LICENSE = "MIT & MIT" |
| 7 | |
| 8 | DEPENDS = "flex-native bison-native" |
| 9 | |
| 10 | SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz" |
| 11 | |
| 12 | SRC_URI[sha256sum] = "560f11c4bbbca10f495f3ef7d3a6aa4ca62b4f8fb0b52e7d459d18a26e46e017" |
| 13 | |
| 14 | UPSTREAM_CHECK_URI = "http://xkbcommon.org/" |
| 15 | |
| 16 | inherit meson pkgconfig |
| 17 | |
| 18 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} xkbregistry" |
| 19 | |
| 20 | PACKAGECONFIG[docs] = "-Denable-docs=true,-Denable-docs=false,doxygen-native" |
| 21 | PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols," |
| 22 | PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config," |
| 23 | PACKAGECONFIG[xkbregistry] = "-Denable-xkbregistry=true,-Denable-xkbregistry=false,libxml2" |
| 24 | |
| 25 | PACKAGE_BEFORE_PN += "xkbcli" |
| 26 | FILES:${PN} = "" |
| 27 | FILES:xkbcli = "${bindir}/xkbcli ${libexecdir}/xkbcommon/xkbcli-*" |
| 28 | |
| 29 | python populate_packages:prepend () { |
| 30 | # Put the libraries into separate packages to avoid dependency creep |
| 31 | do_split_packages(d, d.expand('${libdir}'), r'^(lib.*)\.so\.*', '%s', '%s library', extra_depends='', allow_links=True) |
| 32 | } |
| 33 | |
| 34 | # Fix a following runtime error: |
| 35 | # xkbcommon: ERROR: couldn't find a Compose file for locale "C" |
| 36 | RDEPENDS:${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}" |
| 37 | |
| 38 | BBCLASSEXTEND += "native" |