blob: f99de8409cd31064aabea5e7048d44ededb95952 [file] [log] [blame]
Brad Bishopc7d1cd92020-09-09 09:57:07 -04001SUMMARY = "OpenBMC for AMD - Applications"
2PR = "r1"
3
4inherit packagegroup
5
6PROVIDES = "${PACKAGES}"
7PACKAGES = " \
8 ${PN}-chassis \
9 ${PN}-fans \
10 ${PN}-flash \
11 ${PN}-system \
12 "
13
14PROVIDES += "virtual/obmc-chassis-mgmt"
15PROVIDES += "virtual/obmc-fan-mgmt"
16PROVIDES += "virtual/obmc-flash-mgmt"
Patrick Williams5a5f33c2021-11-03 10:35:37 -050017PROVIDES += "virtual/obmc-system-mgmt"
Brad Bishopc7d1cd92020-09-09 09:57:07 -040018
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030019RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
20RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
21RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
Patrick Williams5a5f33c2021-11-03 10:35:37 -050022RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
Brad Bishopc7d1cd92020-09-09 09:57:07 -040023
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030024SUMMARY:${PN}-chassis = "AMD Chassis"
25RDEPENDS:${PN}-chassis = " \
Brad Bishopc7d1cd92020-09-09 09:57:07 -040026 x86-power-control \
27 obmc-host-failure-reboots \
28 "
29
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030030SUMMARY:${PN}-fans = "AMD Fans"
Konstantin Aladyshev16a9a512021-11-17 08:15:30 +000031RDEPENDS:${PN}-fans = " \
32 phosphor-pid-control \
33 "
Brad Bishopc7d1cd92020-09-09 09:57:07 -040034
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030035SUMMARY:${PN}-flash = "AMD Flash"
36RDEPENDS:${PN}-flash = " \
Brad Bishopc7d1cd92020-09-09 09:57:07 -040037 phosphor-software-manager \
38 "
39
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +030040SUMMARY:${PN}-system = "AMD System"
41RDEPENDS:${PN}-system = " \
Konstantin Aladysheva953aa62021-04-19 11:37:54 +030042 amd-fpga \
Brad Bishopc7d1cd92020-09-09 09:57:07 -040043 bmcweb \
Konstantin Aladyshev62ee4a22021-04-19 11:19:30 +030044 dbus-sensors \
Brad Bishopc7d1cd92020-09-09 09:57:07 -040045 entity-manager \
46 ipmitool \
47 phosphor-hostlogger \
Konstantin Aladyshev5651e682021-04-30 16:56:37 +030048 webui-vue \
Brad Bishopc7d1cd92020-09-09 09:57:07 -040049 "