Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | require gzip.inc |
| 2 | |
| 3 | LICENSE = "GPLv3+" |
| 4 | |
| 5 | SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz \ |
| 6 | file://run-ptest \ |
| 7 | " |
| 8 | SRC_URI_append_class-target = " file://wrong-path-fix.patch" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 11 | file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e" |
| 12 | |
| 13 | PROVIDES_append_class-native = " gzip-replacement-native" |
| 14 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 15 | RDEPENDS_${PN}-ptest += "make perl perl-ptest grep diffutils" |
Brad Bishop | 393846f | 2019-05-20 12:24:11 -0400 | [diff] [blame] | 16 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 17 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | |
| 19 | inherit ptest |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | mkdir -p ${D}${PTEST_PATH}/src/build-aux |
| 23 | cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/src/build-aux/ |
| 24 | mkdir -p ${D}${PTEST_PATH}/src/tests |
| 25 | cp -r ${S}/tests/* ${D}${PTEST_PATH}/src/tests |
| 26 | sed -e 's/^abs_srcdir = ..*/abs_srcdir = \.\./' \ |
| 27 | -e 's/^top_srcdir = ..*/top_srcdir = \.\./' \ |
| 28 | -e 's/^GREP = ..*/GREP = grep/' \ |
| 29 | -e 's/^AWK = ..*/AWK = awk/' \ |
| 30 | -e 's/^srcdir = ..*/srcdir = \./' \ |
| 31 | -e 's/^Makefile: ..*/Makefile: /' \ |
| 32 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 33 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 34 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 35 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ |
| 36 | ${B}/tests/Makefile > ${D}${PTEST_PATH}/src/tests/Makefile |
| 37 | } |
| 38 | |
| 39 | SRC_URI[md5sum] = "cf9ee51aff167ff69844d5d7d71c8b20" |
| 40 | SRC_URI[sha256sum] = "c91f74430bf7bc20402e1f657d0b252cb80aa66ba333a25704512af346633c68" |