blob: ed2b6437dd2f0aee7f29e219988fad41b346802b [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Audio Sample Rate Conversion library"
2DESCRIPTION = "Also known as Secret Rabbit Code - a library for performing sample rate conversion of audio data."
3HOMEPAGE = "https://libsndfile.github.io/libsamplerate/"
4SECTION = "libs"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=336d6faf40fb600bafb0061f4052f1f4 \
7 file://src/samplerate.c;beginline=1;endline=7;md5=7a4238289dc36bfb70968ccaa5bd0d4f"
8DEPENDS = "libsndfile1"
9
10SRC_URI = "https://github.com/libsndfile/libsamplerate/releases/download/${PV}/libsamplerate-${PV}.tar.xz \
11"
12
13SRC_URI[sha256sum] = "3258da280511d24b49d6b08615bbe824d0cacc9842b0e4caf11c52cf2b043893"
14
15CVE_PRODUCT = "libsamplerate"
16
17UPSTREAM_CHECK_URI = "https://github.com/libsndfile/libsamplerate/releases"
18
19S = "${WORKDIR}/libsamplerate-${PV}"
20
21inherit autotools pkgconfig
22
23# FFTW and ALSA are only used in tests and examples, so they don't affect
24# normal builds. It should be safe to ignore these, but explicitly disabling
25# them adds some extra certainty that builds are deterministic.
26EXTRA_OECONF = "--disable-fftw --disable-alsa"