Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 1 | SUMMARY = "Avahi IPv4LL network address configuration daemon" |
| 2 | DESCRIPTION = 'Avahi is a fully LGPL framework for Multicast DNS Service Discovery. It \ |
| 3 | allows programs to publish and discover services and hosts running on a local network \ |
| 4 | with no specific configuration. This tool implements IPv4LL, "Dynamic Configuration of \ |
| 5 | IPv4 Link-Local Addresses" (IETF RFC3927), a protocol for automatic IP address \ |
| 6 | configuration from the link-local 169.254.0.0/16 range without the need for a central \ |
| 7 | server.' |
| 8 | AUTHOR = "Lennart Poettering <lennart@poettering.net>" |
| 9 | HOMEPAGE = "http://avahi.org" |
| 10 | BUGTRACKER = "https://github.com/lathiat/avahi/issues" |
| 11 | SECTION = "network" |
| 12 | |
| 13 | # major part is under LGPLv2.1+, but several .dtd, .xsl, initscripts and |
| 14 | # python scripts are under GPLv2+ |
| 15 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 17 | file://avahi-common/address.h;endline=25;md5=b1d1d2cda1c07eb848ea7d6215712d9d \ |
| 18 | file://avahi-core/dns.h;endline=23;md5=6fe82590b81aa0ddea5095b548e2fdcb \ |
| 19 | file://avahi-daemon/main.c;endline=21;md5=9ee77368c5407af77caaef1b07285969 \ |
| 20 | file://avahi-client/client.h;endline=23;md5=f4ac741a25c4f434039ba3e18c8674cf" |
| 21 | |
| 22 | SRC_URI = "https://github.com/lathiat/avahi/releases/download/v${PV}/avahi-${PV}.tar.gz \ |
| 23 | file://00avahi-autoipd \ |
| 24 | file://99avahi-autoipd \ |
| 25 | file://initscript.patch \ |
| 26 | file://0001-Fix-opening-etc-resolv.conf-error.patch \ |
| 27 | " |
| 28 | |
| 29 | UPSTREAM_CHECK_URI = "https://github.com/lathiat/avahi/releases/" |
| 30 | SRC_URI[md5sum] = "229c6aa30674fc43c202b22c5f8c2be7" |
| 31 | SRC_URI[sha256sum] = "060309d7a333d38d951bc27598c677af1796934dbd98e1024e7ad8de798fedda" |
| 32 | |
| 33 | DEPENDS = "expat libcap libdaemon glib-2.0 intltool-native" |
| 34 | |
| 35 | # For gtk related PACKAGECONFIGs: gtk, gtk3 |
| 36 | AVAHI_GTK ?= "gtk3" |
| 37 | |
| 38 | PACKAGECONFIG ??= "dbus ${@bb.utils.contains_any('DISTRO_FEATURES','x11 wayland','${AVAHI_GTK}','',d)}" |
| 39 | PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus" |
| 40 | PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+" |
| 41 | PACKAGECONFIG[gtk3] = "--enable-gtk3,--disable-gtk3,gtk+3" |
| 42 | PACKAGECONFIG[libdns_sd] = "--enable-compat-libdns_sd --enable-dbus,,dbus" |
| 43 | PACKAGECONFIG[libevent] = "--enable-libevent,--disable-libevent,libevent" |
| 44 | PACKAGECONFIG[qt5] = "--enable-qt5,--disable-qt5,qtbase" |
| 45 | |
| 46 | inherit autotools pkgconfig gettext gobject-introspection |
| 47 | |
| 48 | EXTRA_OECONF = "--with-avahi-priv-access-group=adm \ |
| 49 | --disable-stack-protector \ |
| 50 | --disable-gdbm \ |
| 51 | --disable-dbm \ |
| 52 | --disable-mono \ |
| 53 | --disable-monodoc \ |
| 54 | --disable-qt3 \ |
| 55 | --disable-qt4 \ |
| 56 | --disable-python \ |
| 57 | --disable-doxygen-doc \ |
| 58 | --enable-manpages \ |
| 59 | ${EXTRA_OECONF_SYSVINIT} \ |
| 60 | ${EXTRA_OECONF_SYSTEMD} \ |
| 61 | " |
| 62 | |
| 63 | # The distro choice determines what init scripts are installed |
| 64 | EXTRA_OECONF_SYSVINIT = "${@bb.utils.contains('DISTRO_FEATURES','sysvinit','--with-distro=debian','--with-distro=none',d)}" |
| 65 | EXTRA_OECONF_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES','systemd','--with-systemdsystemunitdir=${systemd_unitdir}/system/','--without-systemdsystemunitdir',d)}" |
| 66 | |
| 67 | do_configure_prepend() { |
| 68 | # This m4 file will get in the way of our introspection.m4 with special cross-compilation fixes |
| 69 | rm "${S}/common/introspection.m4" || true |
| 70 | } |
| 71 | |
| 72 | do_compile_prepend() { |
| 73 | export GIR_EXTRA_LIBS_PATH="${B}/avahi-gobject/.libs:${B}/avahi-common/.libs:${B}/avahi-client/.libs:${B}/avahi-glib/.libs" |
| 74 | } |
| 75 | |
| 76 | RRECOMMENDS_${PN}_append_libc-glibc = " libnss-mdns" |
| 77 | |
| 78 | do_install() { |
| 79 | autotools_do_install |
| 80 | rm -rf ${D}/run |
| 81 | rm -rf ${D}${datadir}/dbus-1/interfaces |
| 82 | test -d ${D}${datadir}/dbus-1 && rmdir --ignore-fail-on-non-empty ${D}${datadir}/dbus-1 |
| 83 | rm -rf ${D}${libdir}/avahi |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 84 | |
| 85 | # Move example service files out of /etc/avahi/services so we don't |
| 86 | # advertise ssh & sftp-ssh by default |
| 87 | install -d ${D}${docdir}/avahi |
| 88 | mv ${D}${sysconfdir}/avahi/services/* ${D}${docdir}/avahi |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 89 | } |
| 90 | |
| 91 | PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "libdns_sd", "libavahi-compat-libdnssd", "", d)}" |
| 92 | |
| 93 | FILES_libavahi-compat-libdnssd = "${libdir}/libdns_sd.so.*" |
| 94 | |
| 95 | RPROVIDES_libavahi-compat-libdnssd = "libdns-sd" |
| 96 | |
| 97 | inherit update-rc.d systemd useradd |
| 98 | |
| 99 | PACKAGES =+ "libavahi-gobject avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-autoipd avahi-utils avahi-discover avahi-ui" |
| 100 | |
| 101 | FILES_avahi-ui = "${libdir}/libavahi-ui*.so.*" |
| 102 | FILES_avahi-discover = "${datadir}/applications/avahi-discover.desktop \ |
| 103 | ${datadir}/avahi/interfaces/avahi-discover.ui \ |
| 104 | ${bindir}/avahi-discover-standalone \ |
| 105 | " |
| 106 | |
| 107 | LICENSE_libavahi-gobject = "LGPLv2.1+" |
| 108 | LICENSE_avahi-daemon = "LGPLv2.1+" |
| 109 | LICENSE_libavahi-common = "LGPLv2.1+" |
| 110 | LICENSE_libavahi-core = "LGPLv2.1+" |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 111 | LICENSE_libavahi-client = "LGPLv2.1+" |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 112 | LICENSE_avahi-dnsconfd = "LGPLv2.1+" |
| 113 | LICENSE_libavahi-glib = "LGPLv2.1+" |
| 114 | LICENSE_avahi-autoipd = "LGPLv2.1+" |
| 115 | LICENSE_avahi-utils = "LGPLv2.1+" |
| 116 | |
| 117 | # As avahi doesn't put any files into PN, clear the files list to avoid problems |
| 118 | # if extra libraries appear. |
| 119 | FILES_${PN} = "" |
| 120 | FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \ |
| 121 | ${sysconfdir}/avahi/avahi-autoipd.action \ |
| 122 | ${sysconfdir}/dhcp/*/avahi-autoipd \ |
| 123 | ${sysconfdir}/udhcpc.d/00avahi-autoipd \ |
| 124 | ${sysconfdir}/udhcpc.d/99avahi-autoipd" |
| 125 | FILES_libavahi-common = "${libdir}/libavahi-common.so.*" |
| 126 | FILES_libavahi-core = "${libdir}/libavahi-core.so.* ${libdir}/girepository-1.0/AvahiCore*.typelib" |
| 127 | FILES_avahi-daemon = "${sbindir}/avahi-daemon \ |
| 128 | ${sysconfdir}/avahi/avahi-daemon.conf \ |
| 129 | ${sysconfdir}/avahi/hosts \ |
| 130 | ${sysconfdir}/avahi/services \ |
| 131 | ${sysconfdir}/dbus-1 \ |
| 132 | ${sysconfdir}/init.d/avahi-daemon \ |
| 133 | ${datadir}/avahi/introspection/*.introspect \ |
| 134 | ${datadir}/avahi/avahi-service.dtd \ |
| 135 | ${datadir}/avahi/service-types \ |
| 136 | ${datadir}/dbus-1/system-services" |
| 137 | FILES_libavahi-client = "${libdir}/libavahi-client.so.*" |
| 138 | FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \ |
| 139 | ${sysconfdir}/avahi/avahi-dnsconfd.action \ |
| 140 | ${sysconfdir}/init.d/avahi-dnsconfd" |
| 141 | FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*" |
| 142 | FILES_libavahi-gobject = "${libdir}/libavahi-gobject.so.* ${libdir}/girepository-1.0/Avahi*.typelib" |
| 143 | FILES_avahi-utils = "${bindir}/avahi-* ${bindir}/b* ${datadir}/applications/b*" |
| 144 | |
| 145 | RDEPENDS_${PN}-dev = "avahi-daemon (= ${EXTENDPKGV}) libavahi-core (= ${EXTENDPKGV})" |
| 146 | RDEPENDS_${PN}-dev += "${@["", " libavahi-client (= ${EXTENDPKGV})"][bb.utils.contains('PACKAGECONFIG', 'dbus', 1, 0, d)]}" |
Andrew Geissler | 5a43b43 | 2020-06-13 10:46:56 -0500 | [diff] [blame] | 147 | RDEPENDS_${PN}-dnsconfd = "${PN}-daemon" |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 148 | |
| 149 | RRECOMMENDS_avahi-daemon_append_libc-glibc = " libnss-mdns" |
| 150 | |
| 151 | CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf" |
| 152 | |
| 153 | USERADD_PACKAGES = "avahi-daemon avahi-autoipd" |
| 154 | USERADD_PARAM_avahi-daemon = "--system --home /run/avahi-daemon \ |
| 155 | --no-create-home --shell /bin/false \ |
| 156 | --user-group avahi" |
| 157 | |
| 158 | USERADD_PARAM_avahi-autoipd = "--system --home /run/avahi-autoipd \ |
| 159 | --no-create-home --shell /bin/false \ |
| 160 | --user-group \ |
| 161 | -c \"Avahi autoip daemon\" \ |
| 162 | avahi-autoipd" |
| 163 | |
| 164 | INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd" |
| 165 | INITSCRIPT_NAME_avahi-daemon = "avahi-daemon" |
| 166 | INITSCRIPT_PARAMS_avahi-daemon = "defaults 21 19" |
| 167 | INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd" |
| 168 | INITSCRIPT_PARAMS_avahi-dnsconfd = "defaults 22 19" |
| 169 | |
| 170 | SYSTEMD_PACKAGES = "${PN}-daemon ${PN}-dnsconfd" |
| 171 | SYSTEMD_SERVICE_${PN}-daemon = "avahi-daemon.service" |
| 172 | SYSTEMD_SERVICE_${PN}-dnsconfd = "avahi-dnsconfd.service" |
| 173 | |
| 174 | do_install_append() { |
| 175 | install -d ${D}${sysconfdir}/udhcpc.d |
| 176 | install ${WORKDIR}/00avahi-autoipd ${D}${sysconfdir}/udhcpc.d |
| 177 | install ${WORKDIR}/99avahi-autoipd ${D}${sysconfdir}/udhcpc.d |
| 178 | } |
| 179 | |
| 180 | # At the time the postinst runs, dbus might not be setup so only restart if running |
| 181 | # Don't exit early, because update-rc.d needs to run subsequently. |
| 182 | pkg_postinst_avahi-daemon () { |
| 183 | if [ -z "$D" ]; then |
| 184 | killall -q -HUP dbus-daemon || true |
| 185 | fi |
| 186 | } |
| 187 | |