blob: f11fcd012b42fa18026cff46674def23f117dfbf [file] [log] [blame]
Adriana Kobylakc763ceb2018-06-04 13:06:52 -05001# UBI-specific configuration for the phosphor-manager-software package
2
Lei YU1873aa12018-05-23 10:53:24 +08003PACKAGECONFIG_append = " ubifs_layout"
4
Adriana Kobylakc763ceb2018-06-04 13:06:52 -05005RDEPENDS_phosphor-software-manager-updater-ubi += " \
6 bash \
7 mtd-utils-ubifs \
8"
9
10FILES_${PN}-updater-ubi += " \
11 ${sbindir}/obmc-flash-bmc \
12 /usr/local \
13 "
14
15SYSTEMD_SERVICE_phosphor-software-manager-updater-ubi += " \
16 obmc-flash-bmc-ubirw.service \
17 obmc-flash-bmc-ubiro@.service \
18 obmc-flash-bmc-setenv@.service \
19 obmc-flash-bmc-ubirw-remove.service \
20 obmc-flash-bmc-ubiro-remove@.service \
21 obmc-flash-bmc-ubiremount.service \
22 obmc-flash-bmc-updateubootvars@.service \
23 obmc-flash-bmc-cleanup.service \
24 obmc-flash-bmc-mirroruboot.service \
25 reboot-guard-enable.service \
26 reboot-guard-disable.service \
27 usr-local.mount \
28"
29
30# Name of the mtd device where the ubi volumes should be created
31BMC_RW_MTD ??= "bmc"
32BMC_RO_MTD ??= "bmc"
33BMC_KERNEL_MTD ??= "bmc"
34BMC_RW_SIZE ??= "0x600000"
35SYSTEMD_SUBSTITUTIONS += "RW_MTD:${BMC_RW_MTD}:obmc-flash-bmc-ubirw.service"
36SYSTEMD_SUBSTITUTIONS += "RO_MTD:${BMC_RO_MTD}:obmc-flash-bmc-ubiro@.service"
37SYSTEMD_SUBSTITUTIONS += "KERNEL_MTD:${BMC_KERNEL_MTD}:obmc-flash-bmc-ubiro@.service"
38SYSTEMD_SUBSTITUTIONS += "RW_SIZE:${BMC_RW_SIZE}:obmc-flash-bmc-ubirw.service"
39
40SRC_URI += "file://obmc-flash-bmc"
41SRC_URI += "file://synclist"
42do_install_append() {
43 install -d ${D}${sbindir}
44 install -m 0755 ${WORKDIR}/obmc-flash-bmc ${D}${sbindir}/obmc-flash-bmc
45 install -d ${D}/usr/local
46
47 if [ -f ${WORKDIR}/build/phosphor-sync-software-manager ]; then
48 install -d ${D}${sysconfdir}
49 install -m 0644 ${WORKDIR}/synclist ${D}${sysconfdir}/synclist
50 fi
51}