blob: 01c621441f1aca8c610247ce728fd9d90e434f5f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
12DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native"
13
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
Andrew Geissler1548c072019-02-22 16:03:50 -060015 file://0001-Do-not-set-Wno-unused-but-set-variable.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 "
17
18SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0"
19SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80"
20
21S = "${WORKDIR}/ModemManager-${PV}"
22
23PACKAGECONFIG ??= "mbim qmi polkit \
24 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
25"
26
27PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
28PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
29# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
30PACKAGECONFIG[mbim] = "--with-mbim,--with-mbim=no,libmbim"
31# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
32PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
33
34EXTRA_OECONF = " \
35 --with-udev-base-dir=${nonarch_base_libdir}/udev \
36"
Andrew Geissler1548c072019-02-22 16:03:50 -060037CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
39FILES_${PN} += " \
40 ${datadir}/icons \
41 ${datadir}/polkit-1 \
42 ${datadir}/dbus-1 \
43 ${libdir}/ModemManager \
44 ${systemd_unitdir}/system \
45"
46
47FILES_${PN}-dev += " \
48 ${libdir}/ModemManager/*.la \
49"
50
51FILES_${PN}-staticdev += " \
52 ${libdir}/ModemManager/*.a \
53"
54
55FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
56
57SYSTEMD_SERVICE_${PN} = "ModemManager.service"