blob: dec4b679731a5ce6ea6a87f77b3c96e08850b535 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection bash-completion
11
12DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native"
13
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
15 "
16
17SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0"
18SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80"
19
20S = "${WORKDIR}/ModemManager-${PV}"
21
22PACKAGECONFIG ??= "mbim qmi polkit \
23 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
24"
25
26PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
27PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
28# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
29PACKAGECONFIG[mbim] = "--with-mbim,--with-mbim=no,libmbim"
30# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
31PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
32
33EXTRA_OECONF = " \
34 --with-udev-base-dir=${nonarch_base_libdir}/udev \
35"
36
37FILES_${PN} += " \
38 ${datadir}/icons \
39 ${datadir}/polkit-1 \
40 ${datadir}/dbus-1 \
41 ${libdir}/ModemManager \
42 ${systemd_unitdir}/system \
43"
44
45FILES_${PN}-dev += " \
46 ${libdir}/ModemManager/*.la \
47"
48
49FILES_${PN}-staticdev += " \
50 ${libdir}/ModemManager/*.a \
51"
52
53FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
54
55SYSTEMD_SERVICE_${PN} = "ModemManager.service"