blob: 4c7755cba3f7ac807e10eec04415b3a85b88fb52 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "The tdb library"
2HOMEPAGE = "http://tdb.samba.org/"
3SECTION = "libs"
4LICENSE = "LGPL-3.0+ & GPL-3.0+"
5
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
10 file://do-not-check-xsltproc-manpages.patch \
11 file://tdb-Add-configure-options-for-packages.patch \
12 file://0001-waf-add-support-of-cross_compile.patch \
13 file://0001-Makefile-fix-problem-that-waf-cannot-found.patch \
14"
15
16SRC_URI[md5sum] = "519d373ac72a66b0a2739dbb495de127"
17SRC_URI[sha256sum] = "1cb4399394c60a773430ca54848359adcf54fb6f136afdcfcbbe62b5f4245614"
18
19PACKAGECONFIG ??= "\
20 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
22"
23
24PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
25PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
26PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
27PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
28PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
29PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
30
31S = "${WORKDIR}/tdb-${PV}"
32
33inherit waf-samba
34
35#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
36#to cross Popen
37export WAF_NO_PREFORK="yes"
38
39EXTRA_OECONF += "--disable-rpath \
40 --bundled-libraries=NONE \
41 --builtin-libraries=replace \
42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
43 "
44
45PACKAGES += "tdb-tools python-tdb"
46
47RPROVIDES_${PN}-dbg += "python-tdb-dbg"
48
49FILES_${PN} = "${libdir}/*.so.*"
50FILES_tdb-tools = "${bindir}/*"
51FILES_python-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
52RDEPENDS_python-tdb = "python"