blob: 038c1617fcfe352d27ae4faeb73ab0635d41bbc6 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A sophisticated network protocol analyzer"
2HOMEPAGE = "http://www.tcpdump.org/"
Brad Bishop19323692019-04-05 15:28:33 -04003SECTION = "net"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05004LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1d4b0366557951c84a94fabe3529f867"
Brad Bishop19323692019-04-05 15:28:33 -04006
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007DEPENDS = "libpcap"
8
9SRC_URI = " \
10 http://www.tcpdump.org/release/${BP}.tar.gz \
11 file://unnecessary-to-check-libpcap.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 file://avoid-absolute-path-when-searching-for-libdlpi.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013 file://add-ptest.patch \
14 file://run-ptest \
15"
16
17SRC_URI[md5sum] = "9bbc1ee33dab61302411b02dd0515576"
18SRC_URI[sha256sum] = "798b3536a29832ce0cbb07fafb1ce5097c95e308a6f592d14052e1ef1505fe79"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020inherit autotools-brokensep ptest
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG ?= "openssl"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023
Brad Bishop19323692019-04-05 15:28:33 -040024PACKAGECONFIG[libcap-ng] = "--with-cap-ng,--without-cap-ng,libcap-ng"
25PACKAGECONFIG[openssl] = "--with-crypto,--without-openssl --without-crypto,openssl"
26PACKAGECONFIG[smi] = "--with-smi,--without-smi,libsmi"
27
28EXTRA_AUTORECONF += "-I m4"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029
30do_configure_prepend() {
31 mkdir -p ${S}/m4
32 if [ -f aclocal.m4 ]; then
33 mv aclocal.m4 ${S}/m4
34 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035}
36
37do_install_append() {
Brad Bishop19323692019-04-05 15:28:33 -040038 # make install installs an unneeded extra copy of the tcpdump binary
Brad Bishop6e60e8b2018-02-01 10:27:11 -050039 rm -f ${D}${sbindir}/tcpdump.${PV}
40}
41
42do_compile_ptest() {
43 oe_runmake buildtest-TESTS
44}