blob: 4edb2e6644ff2728db683541cbb8216d09d88d90 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "Linux user-space application to modify the EFI Boot Manager."
2SUMMARY = "EFI Boot Manager"
3HOMEPAGE = "https://github.com/rhinstaller/efibootmgr"
4SECTION = "base"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
8
9DEPENDS = "pciutils zlib efivar"
10
11COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
12
13SRCREV = "e067160ecef8208e1944002e5d50b275733211fb"
14SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
15 file://0001-remove-extra-decl.patch \
16 "
17S = "${WORKDIR}/git"
18
19inherit pkgconfig
20
21EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
22
23CFLAGS_append_toolchain-clang = " -Wno-error"
24do_install () {
25 install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
26}
27
28CLEANBROKEN = "1"