blob: 99cfb32051c818a39c29af00e0e19da4898bdf91 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Wi-Fi Test Suite Linux Control Agent"
2DESCRIPTION = "Wi-Fi Test Suite is a software platform originally developed \
3by Wi-Fi Alliance, the global non-profit industry association that brings you \
4Wi-Fi, to support certification program development and device certification."
5HOMEPAGE = "https://www.wi-fi.org/certification/wi-fi-test-suite"
6LICENSE = "ISC"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=0542427ed5c315ca34aa09ae7a85ed32"
8SECTION = "test"
9
10S = "${WORKDIR}/git"
11SRCREV = "f7a8d7ef7d1a831c1bb47de21fa083536ea2f3a9"
12SRC_URI = "git://github.com/Wi-FiTestSuite/Wi-FiTestSuite-Linux-DUT.git \
13 file://0001-Use-toolchain-from-environment-variables.patch \
14 file://0002-Add-missing-include-removes-unnedded-stuff-and-add-n.patch \
15 file://0003-fix-path-to-usr-sbin-for-script-and-make-script-for-.patch \
16 file://0004-run-ranlib-per-library-and-use-AR.patch \
17"
18
19# to avoid host path QA error
20CFLAGS += "-I${STAGING_INCDIR}/tirpc"
21# Fix GNU HASH error
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24do_install () {
25 install -d ${D}${libdir}
26 install -m 0644 ${S}/lib/libwfa.a ${D}${libdir}
27 install -m 0644 ${S}/lib/libwfa_ca.a ${D}${libdir}
28 install -m 0644 ${S}/lib/libwfa_dut.a ${D}${libdir}
29 install -d ${D}${sbindir}
30 install -m 0755 ${S}/dut/wfa_dut ${D}${sbindir}
31 install -m 0755 ${S}/ca/wfa_ca ${D}${sbindir}
32 install -m 0755 ${S}/scripts/*.sh ${D}${sbindir}
33 install -m 0755 ${S}/scripts/arp_neigh_loop ${D}${sbindir}
34 install -m 0755 ${S}/scripts/dev_send_frame ${D}${sbindir}
35 install -m 0755 ${S}/scripts/sta_reset_parm ${D}${sbindir}
36}
37
38RDEPENDS_${PN} = "wpa-supplicant"