blob: 305977e5e1040b7f676a6d1d6519ff878f17ca8c [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
4 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background. \
6"
7
8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
9SECTION = "base"
10
11LICENSE = "GPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
14
15DEPENDS = "libcap libpng cairo dbus udev"
16PROVIDES = "virtual/psplash"
17RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
18
19SRC_URI = " \
20 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.xz \
21 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
22 "
23
24SRC_URI[md5sum] = "4efa5551d230165981b105e7c6a50aa7"
25SRC_URI[sha256sum] = "4a197a4f1a05785d7453dd829b231352fb2d09171bd86c5ffaafbb2dd6791351"
26
27EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
28 --with-logo=${LOGO} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
30"
31
32PACKAGECONFIG ??= "pango initrd"
33PACKAGECONFIG_append_x86 = " drm"
34PACKAGECONFIG_append_x86-64 = " drm"
35
36PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
37PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
38PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
39PACKAGECONFIG[initrd] = ",,,"
40
41LOGO ??= "${datadir}/plymouth/bizcom.png"
42
43inherit autotools pkgconfig systemd
44
45do_install_append() {
46 # Remove /var/run from package as plymouth will populate it on startup
47 rm -fr "${D}${localstatedir}/run"
48
49 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
50 rm -rf "${D}${libexecdir}"
51 fi
52}
53
54PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
55PACKAGES =+ "${PN}-set-default-theme"
56
57FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
58FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
59
60FILES_${PN} += "${systemd_unitdir}/system/*"
61FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
62
63
64RDEPENDS_${PN}-initrd = "bash dracut"
65RDEPENDS_${PN}-set-default-theme = "bash"
66
67SYSTEMD_SERVICE_${PN} = "plymouth-start.service"