blob: 32aab59f160198aeaeb6831367c1cdc60d6d7045 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8# v1.9.4
9SRCREV = "faa40ff345af194d3253f5fb030403e3c9831c36"
10SRC_URI = "git://github.com/jirka-h/haveged.git \
11 file://haveged-init.d-Makefile.am-add-missing-dependency.patch \
12"
13S = "${WORKDIR}/git"
14
15UPSTREAM_CHECK_URI = "https://github.com/jirka-h/haveged/releases"
16
17inherit autotools update-rc.d systemd
18
19EXTRA_OECONF = "\
20 --enable-nistest=yes \
21 --enable-olt=yes \
22 --enable-threads=no \
23"
24
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
26PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd"
27
28INITSCRIPT_PACKAGES = "${PN}"
29INITSCRIPT_NAME = "haveged"
30INITSCRIPT_PARAMS_${PN} = "defaults 9"
31
32SYSTEMD_PACKAGES = "${PN}"
33SYSTEMD_SERVICE_${PN} = "haveged.service"
34
35do_install_append() {
36 # The exit status is 143 when the service is stopped
37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service
39 fi
40}
41
42MIPS_INSTRUCTION_SET = "mips"