blob: 8152ca7ca34111b16f000f03e0b40457c2bc619e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libsigrok is a shared library written in C, which provides the basic hardware access drivers for logic analyzers and other supported devices, as well as input/output file format support."
2HOMEPAGE = "http://sigrok.org/wiki/Main_Page"
3
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = "glib-2.0 libzip"
8
9PACKAGECONFIG[serialport] = "--with-libserialport,--without-libserialport,libserialport"
10PACKAGECONFIG[ftdi] = "--with-libftdi,--without-libftdi,libftdi"
11PACKAGECONFIG[usb] = "--with-libusb,--without-libusb,libusb"
12PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,glibmm doxygen-native"
13
14PACKAGECONFIG ??= "serialport ftdi usb"
15
16inherit autotools pkgconfig
17
18SRC_URI = "http://sigrok.org/download/source/libsigrok/libsigrok-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "a3de9e52a660e51d27a6aca025d204a7"
21SRC_URI[sha256sum] = "e40fde7af98d29e922e9d3cbe0a6c0569889153fc31e47b8b1afe4d846292b9c"
22
23FILES_${PN} += "${datadir}/*"