blob: a9efffaca248d77c4b4816950f6d5eee136135dd [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Graph Visualization Tools"
2HOMEPAGE = "http://www.graphviz.org"
3LICENSE = "EPL-1.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=9109f5fc16cf963fb3cdd32781b3ce04"
5
6DEPENDS = " \
7 intltool-native \
8 bison-native \
9 groff-native \
10 libtool \
11 gdk-pixbuf \
12 librsvg \
13 cairo \
14 pango \
15 expat \
16 freetype \
17"
18DEPENDS_append_class-target = " ${BPN}-native"
19
20inherit autotools-brokensep pkgconfig gettext
21
22# The source tarball suggested at
23# https://graphviz.gitlab.io/_pages/Download/Download_source.html has no
24# version in its name. So once graphviz is updgraded, only first time users will
25# get checksum errors. Fedora people seem to expect same so they use a versioned
26# source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec
27
28SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \
29"
30# Use native mkdefs
31SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch"
32SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
33SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
34
35S = "${WORKDIR}/${BPN}-stable_release_${PV}"
36
37EXTRA_OECONF_class-target = "\
38 --with-expatincludedir=${STAGING_INCDIR} \
39 --with-expatlibdir=${STAGING_LIBDIR} \
40 --without-included-ltdl \
41 --disable-java \
42 --disable-r \
43 --disable-sharp \
44 "
45CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
46do_configure_prepend() {
47 cd ${S}
48 # create version.m4 and ignore libtoolize errors
49 ./autogen.sh NOCONFIG || true
50}
51
52do_install_append_class-native() {
53 # install mkdefs for target build
54 install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
55}
56
57FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
58
59BBCLASSEXTEND = "native"