blob: 863ce428f198a9fbc08e8f60242ed54859f3b101 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "The goal of this project is to provide a tiny library that would \
2facilitate the common operations with sizes in bytes."
3HOMEPAGE = "https://github.com/rhinstaller/libbytesize"
4LICENSE = "LGPLv2+"
5SECTION = "devel/lib"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
8
9S = "${WORKDIR}/git"
10B = "${S}"
11
12SRCREV = "ebbda2217d177d2a17f917d7a3e3d132a26db791"
13SRC_URI = "git://github.com/rhinstaller/libbytesize;branch=master \
14"
15
16inherit gettext autotools python3native
17
18DEPENDS += " \
19 libpcre \
20 gmp \
21 mpfr \
22"
23
24FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/bytesize"
25
26PACKAGECONFIG ??= "python3"
27PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
28PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
29PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
30
31EXTRA_OEMAKE = "py3libdir=${PYTHON_SITEPACKAGES_DIR}"
32
33