blob: 888c729b3e935339bda33c169d6549cd1d0447c2 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001#
2# Copyright (C) 2012 Wind River Systems, Inc.
3#
4SUMMARY = "MCE test suite"
5
6DESCRIPTION = "The MCE test suite is a collection of tools and test scripts for \
7testing the Linux RAS related features, including CPU/Memory error \
8containment and recovery, ACPI/APEI support etc."
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
12
13SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mce-test.git;protocol=git \
14 file://makefile-remove-ldflags.patch \
15 "
16SRCREV = "74bffd8b0aa27051aeaa1983a7b23975ca8d8726"
17PV = "20171030+git${SRCPV}"
18
19RDEPENDS_${PN} = "mcelog mce-inject dialog bash"
20
21COMPATIBLE_HOST = '(i.86|x86_64).*-linux'
22
23S ="${WORKDIR}/git"
24
25do_install_append(){
26 install -d ${D}/opt/mce-test
27 cp -rf ${S}/* ${D}/opt/mce-test/
28}
29
30FILES_${PN} += "/opt"