blob: 08d6616401ffd21f1f9713ee3dcd4b6a607d187b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
2TDD and BDD - using C++11, C++14, C++17 and later."
3AUTHOR = "Phil Nash, Martin Horenovsky and others"
4HOMEPAGE = "https://github.com/catchorg/Catch2"
5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7
8SRC_URI = "git://github.com/catchorg/Catch2.git \
9 file://0001-Fix-Wdefaulted-function-deleted-warning.patch \
10 "
11# v2.6.1
12SRCREV = "dbbab8727c342733f75045483048cdcb52421e32"
13
14S = "${WORKDIR}/git"
15
16inherit cmake python3native
17
18do_install_append() {
19 rm ${D}${datadir}/Catch2/lldbinit
20 rm ${D}${datadir}/Catch2/gdbinit
21 rmdir ${D}${datadir}/Catch2/
22}
23# Header-only library
24RDEPENDS_${PN}-dev = ""
25RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"